خطر نسخه‌های قدیمی گیت برای کاربران سیستم عامل مک

یکی از ابزار توسعه خط فرمان (command line developer) موجود در سیستم عامل مک حاوی نسخه‌ای قدیمی از سیستم مدیریت کدهای منبع گیت یا Git است که اجرای کدهای مخرب هکرها را از راه دور ممکن می‌کند.

موبنا -به گزارش جاواورلد، کلاینت گیت به توسعه دهندگان و برنامه نویسان امکان تعامل با مخازن کدمنبع را می دهد و البته بر روی سیستم عامل مک به طور پیش فرض نصب نشده، اما در بسته ابزار Command Line برای Xcode که توسط اپل عرضه شد موجود بوده است.

برخی نرم افزارنویسان طراح برنامه برای سیستم عامل های OS X یا iOSاز Xcode استفاده می‌کنند و لذا بسته مربوطه را بر روی رایانه های مک خود نصب کرده اند. آخرین نسخه از این بسته که حاوی گیت نسخه 2.6.4 بود در دسامبر عرضه شد.

نسخه یاد شده دارای دو آسیب پذیری جدی است که با عناوین CVE-2016-2315 و CVE-2016-2324 مشخص شده و هم بر روی سرور و هم کلاینت تاثیر منفی می گذارند. این مشکلات در نسخه Git 2.7.4 که در 17 مارس عرضه شده برطرف شده اند و قرار است اپل این به روزرسانی ها را در بسته ابزار خط فرمان یا Command Line خود بگنجاند.

 منبع: فارس

پاسخ دهید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

18 − 3 =

دنبال کنید @ اینستاگرام